chrometweaks.org

Domain transfer problem from network solutions to iPage - 1 year missing?

Click Here To View All Answers...


First of all Domain transfer problem from network solutions to iPage - 1 year missing? Thanks for any comment. Another question on my mind: Has anyone seen this error before?.

0 -.

Insert into products_to_categories (products_id, categories_id) values ('0', '0').

[TEP STOP].

This happens after I attempt to insert a new product (/admin/categories.php?cPath=&action=insert_product). I ran across a.

SIMILAR TOPIC.

, however I don't believe it completely relates. I've already tried replacing the categories.php file, and no luck. Any idea what's happening??.

Nathan..

Comments (97)

I would like to know the answer too. Anyone here know what is the answer to that question. I'll do some poking around and get back to you if I got an anything. You should email the people at iPage as they probably could help you..

Comment #1

This is happening when I attempt to add a new.

Product item or category folder.

Into a category. What is strange and might make some sense. Is that I notice the error doesn't come up the first time I attempt to insert an.

Product item or category folder.

Into a category, it only happens the second time..

Note, that the first time I attempt to insert a.

Product item or category folder.

Nothing gets inserted. It's as if nothing happened, and no product or folder is selected..

FOR EXAMPLE, If I was to try inserting a category (not a product) called "Fishing Supplies" into osCommerce the url will look like this:.

/admin/categories.php?cPath=&cID=0.

, with nothing inserted.

And then the second time, trying the same thing, the url will look like this:.

/admin/categories.php?action=insert_category&cPath=.

, with a nasty error message reading:.

0 -.

Insert into categories_description (categories_name, categories_id, language_id) values ('Fishing Supplies', '0', '1').

[TEP STOP].

This post has been edited by.

Fifthnail.

: 22 June 2004, 16:30..

Comment #2

Did you modify the database in any way? it seems that the categories name is not auto incrementing..

On another note, all the domains you have listed in your signature area do not go there, they belong in the profile area only, per forum rules...

Comment #3

I don't believe I touched the database. Where would I go to make sure auto incrementing is set on?.

This post has been edited by.

Fifthnail.

: 22 June 2004, 16:57..

Comment #4

Open the database, look at the categories and categories_desctiption tables, see how the categories id field is set. must be done via mysql, mysql connector or phpmyadmin..

Comment #5

I think it's something higher level then this because the same issue occurs when inserting products, not just for categories. For the sake of being thorough about this..

Under the categories table.

Categories_id.

Is set to.

Auto_increment.

Under the categories_description table.

Categories_id.

Type: int(11) Attributes: BLANK Null: No Default: 0 & (in same order) language_id int(11) BLANK No 1 & categories_name varchar(32) BLANK No BLANK...

Comment #6

What changes have you made to the categories.php file?..

Comment #7

The only change I made was to password protect the categories.php file. I password protects this particular file. I believe that had no impact on it whatsoever, I may be wrong. I also added a new line in admin/include/configure.php to define "DIR_FS_WEBROOT" a new variable to track where the absolute path of where my files the password verification..

<?php.

/*.

$Id: categories.php,v 1.146 2003/07/11 14:40:27 hpdl Exp $.

OsCommerce, Open Source E-Commerce Solutions.

Http://www.oscommerce.com.

Copyright (c) 2003 osCommerce.

Released under the GNU General Public License.

*/.

Require('includes/application_top.php');.

/* Check Security Level For Admin*/.

Require_once (DIR_FS_WEBROOT.'/login/auth.php');.

Require_once (DIR_FS_WEBROOT.'/login/authconfig.php');.

Require_once (DIR_FS_WEBROOT.'/login/check.php');.

If ($check["level"] != 1).

{.

Print "<font face=\"Arial, Helvetica, sans-serif\" size=\"5\" color=\"#FF0000\">";.

Print "<b>Illegal Access</b>";.

Print "</font><br>";.

Print "<font face=\"Verdana, Arial, Helvetica, sans-serif\" size=\"2\" color=\"#000000\">";.

Print "<b>You do not have permission to view this page.</b></font>";.

Exit; // End program execution. This will disable continuation of processing the rest of the page..

}.

Require(DIR_WS_CLASSES'currencies.php');.

$currencies = new currencies();.

Note that I've edited all the other files under admin with this security feature, and I can still read and write just the same..

This post has been edited by.

Fifthnail.

: 22 June 2004, 18:01..

Comment #8

What would cause this insertion error? What files are involved with inserting records? Do I need to start looking at code?.

Is the "[TEP STOP]" message supposed to give me any clue as to what is happening??..

Comment #9

I GOT IT WORKING!.

Whatever was the actuall problem doesn't matter anymore - I resolved this issue myself by copying over all the files from the ADMIN directory and the ADMIN > INCLUDE directory (except for the configure.php) and I got it working again. Unfortunately I lost some of my security settings - perhaps that was the issue after all..

So as a lesson to all, becareful when you integrate various programs...

Comment #10

Has anyone seen this error before?.

0 -.

Insert into products_to_categories (products_id, categories_id) values ('0', '0').

[TEP STOP].

This happens after I attempt to insert a new product (/admin/categories.php?cPath=&action=insert_product). I ran across a.

SIMILAR TOPIC.

, however I don't believe it completely relates. I've already tried replacing the categories.php file, and no luck. Any idea what's happening??.

Nathan..

Comment #11

When is this part happening? there is no products_id of value 0...

Comment #12


This question was taken from a support group/message board and re-posted here so others can learn from it.