chrometweaks.org

How do I create a login system with thats compatible with iPage Hosting?

Click Here To View All Answers...


My first question is How do I create a login system with thats compatible with iPage Hosting? Looking forward for any answer or 2. Another question on my mind: I have a iPage website that sells boots. I have been spending along time adding each attribute to each boot, width and boot size..

When you set it up you do the Options first, then the values for the options. I would assume since you set up the options then the values that for each product you should be able to just set the option then it would auto add the values. But instead I have to manually add each size to every shoe. Am I missing something?.

Or do you really have to go through each item over and over adding the item attributes??.

Here is the iPage site to take a peek bootplace.com.

Thanks!!.

Jocelyn..

Comments (68)

Good question... I dunno what is the answer. I'll do some research and get back to you if I got an good answer. You should email the people at iPage as they probably can help you..

Comment #1

Ok, I figured that one out. But now when I go to add a product attribute to an item I get this error: 1136 - Column count doesn't match value count at row 1.

Insert into products_attributes values ('', '78', '6', '43', '', '+').

[TEP STOP].

Thanks..

Comment #2

[B]I get the same thing???.

1136 - Column count doesn't match value count at row 1.

Insert into products_attributes values ('', '136', '10', '24', '28.00', '+').

[TEP STOP].

Numbers ARE DIFFERENT but the same other wise...

HELP......

This post has been edited by.

Guido1229.

: 17 June 2004, 01:58..

Comment #3

Well I don't get that error anymore, I get this horrible error when I click on product attributes in the admin panel:.

Fatal error: Cannot redeclare tep_db_connect() (previously declared in /hsphere/local/home/xxxx/xxxx.com/admin/includes/functions/database.php:13) in /hsphere/local/home/xxxx/xxxx.com/admin/includes/functions/database.php on line 13.

The X's are just shading out my name and place...

Comment #4

Whoops, I got that error taken care of, sent the wrong product attributes.php file over. Still looking for hope on the other problem though.....

Comment #5

Ok it is ME again. But after sifting and sifting I finally found the error. Here is what you want to change....

In catalog/admin/products_attributes.php I changed this:.

Tep_db_query("insert into "TABLE_PRODUCTS_ATTRIBUTES" values ('', '"(int)$products_id"'.

, '"(int)$options_id"', '"(int)$values_id"', '"tep_db_input($value_price)"', '"tep_db_.

Input($price_prefix)"')");.

To this:.

Tep_db_query("insert into "TABLE_PRODUCTS_ATTRIBUTES" values ('', '"(int)$products_id"'.

, '"(int)$options_id"', '"(int)$values_id"', '"tep_db_input($value_price)"', '"tep_db_.

Input($price_prefix)"', '0')");.

It is just at the very last part where you need a comma and a zero!!!.

Good luck!!!..

Comment #6

I have a iPage website that sells boots. I have been spending along time adding each attribute to each boot, width and boot size..

When you set it up you do the Options first, then the values for the options. I would assume since you set up the options then the values that for each product you should be able to just set the option then it would auto add the values. But instead I have to manually add each size to every shoe. Am I missing something?.

Or do you really have to go through each item over and over adding the item attributes??.

Here is the iPage site to take a peek bootplace.com.

Thanks!!.

Jocelyn..

Comment #7

Ok I did download that and followed the directions, but I dont understand what I am suppose to do with this line..

7) modify products_attributes table by running this sql:.

ALTER TABLE `products_attributes` ADD `sort_order` INT(11) UNSIGNED DEFAULT "0".

Or use attributes_copier.sql script.

Can anybody help out?..

Comment #8


This question was taken from a support group/message board and re-posted here so others can learn from it.