chrometweaks.org

What is the best web hosting service out there? (Don't say iPage)?

Click Here To View All Answers...


My question is What is the best web hosting service out there? (Don't say iPage)? Hoping for any comment. Second question of mine... Hi there,.

I got a shared SSL from my iPage hosting company and it works well mostly. However, I noticed that the SSL url interfears with other pages (I set up osCommerce in a separated directory from the main site). For instance, when I click "Continue" button for "notify me for updates on my ordered list" at the end of the order, I get "page not found" error. Also, when I go to other pages in the main iPage site (Home, About us...etc), the SSL url still exists in the Address box of the the web browser..

When I change SSL setting to "false" in configure.php, I don't have any problems..

Any suggestions???.

Thanks very much in advance!..

Comments (58)

Hmm... I need to find out myself. I don't know what is the answer to your question. I'll do some poking around and get back to you if I find an good answer. You should email the people at iPage as they probably can help you..

Comment #1

Thanks for your help and here is the configure.php file..

Define('HTTP_SERVER', 'http://www.mywebsite.com'); // eg,.

Http://localhost.

- should not be empty for productive servers.

Define('HTTPS_SERVER', 'https://ssl.myhosting.com/mywebsite.com/www/shop/'); // eg,.

Https://localhost.

- should not be empty for productive servers.

Define('ENABLE_SSL', false); // secure webserver for checkout procedure?.

Define('HTTP_COOKIE_DOMAIN', 'www.mywebsite.com');.

Define('HTTPS_COOKIE_DOMAIN', '');.

Define('HTTP_COOKIE_PATH', '/shop/');.

Define('HTTPS_COOKIE_PATH', '');.

Define('DIR_WS_HTTP_CATALOG', '/shop/');.

Define('DIR_WS_HTTPS_CATALOG', '');.

Define('DIR_WS_IMAGES', 'images/');.

Define('DIR_WS_ICONS', DIR_WS_IMAGES'icons/');.

Define('DIR_WS_INCLUDES', 'includes/');.

Define('DIR_WS_BOXES', DIR_WS_INCLUDES'boxes/');.

Define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES'functions/');.

Define('DIR_WS_CLASSES', DIR_WS_INCLUDES'classes/');.

Define('DIR_WS_MODULES', DIR_WS_INCLUDES'modules/');.

Define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES'languages/');.

Define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');.

Define('DIR_FS_CATALOG', '/home/webusers/y/mywebsite.com/www/shop/');.

Define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG'download/');.

Define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG'pub/');.

// define our database connection.

Define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers.

Define('DB_SERVER_USERNAME', 'user');.

Define('DB_SERVER_PASSWORD', 'password');.

Define('DB_DATABASE', 'dbname');.

Define('USE_PCONNECT', 'true'); // use persistent connections?.

Define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'..

Comment #2

Can you repost the following lines from your configure.php.

As they are.

And we might be able to help....

Fixing your example config, it would look something like this:.

Cheers.

Rob.

This post has been edited by.

RObW.

: 24 June 2004, 17:38..

Comment #3

First off, I really appreciate your help..

I changed the configure.php file as your instruction and works fine (I don't get "page not found" error anymore at the end). However, the SSL url is still there when I come back to the home page of the shopping cart after shopping. Is this supposed to be like this? Also, when I go to the other pages in the main site, the SSL url comes with it..

I noticed that when I go to the information pages which come with osCommerce such as "contact us, privacy notice...etc), the SSL url disappears..

Is this some kind bug or can I fix this problem?.

Thanks again...

Comment #4

When you login, you should see the main page in SSL. You will find that going to a category, manufacturer or information page will take you back to NONSSL, however all other account related pages are in SSL..

After an order you remain in SSL until you log off or visit a page described above..

Glad that your issue is now fixed..

Regards.

Rob..

Comment #5

Hi there,.

I got a shared SSL from my iPage hosting company and it works well mostly. However, I noticed that the SSL url interfears with other pages (I set up osCommerce in a separated directory from the main site). For instance, when I click "Continue" button for "notify me for updates on my ordered list" at the end of the order, I get "page not found" error. Also, when I go to other pages in the main iPage site (Home, About us...etc), the SSL url still exists in the Address box of the the web browser..

When I change SSL setting to "false" in configure.php, I don't have any problems..

Any suggestions???.

Thanks very much in advance!..

Comment #6

Sounds like an error in your configure.php file. Post a link and also your configure.php file (block out the database info)...

Comment #7


This question was taken from a support group/message board and re-posted here so others can learn from it.