chrometweaks.org

Who is the best low-priced domain registrar other than iPage?

Click Here To View All Answers...


Quick question... Who is the best low-priced domain registrar other than iPage? Many thanks for any answer. Another question... This is something that I got fixed when I added session_force_cooke to MS1. I have just installed MS2..

The problem is that, with force cookies on, when I login I get transferred to the secured page, My account, showing my old cart items. But when I go to any unsecured pages I'm no longer logged in. Going back to secured page I'm logged in already..

I see there're two cookies stored: each from http and https domains. So there are two cookie sessions at the same time but they don't "talk" to one another..

Should there be 2 cookies? MS2 is fixed for shared SSL which is what I'm using. Please help!.

My "configure.php".

Define('HTTP_SERVER', 'http://www.domain.net'); // eg, http://localhost - should not be empty for productive servers.

 define('HTTPS_SERVER', 'https://secure.domain.com/~user'); // eg, https://localhost - should not be empty for productive servers.

 define('ENABLE_SSL', true); // secure webserver for checkout procedure?.

 define('HTTP_COOKIE_DOMAIN', '.domain.net');.

 define('HTTPS_COOKIE_DOMAIN', 'secure.domain.com');.

 define('HTTP_COOKIE_PATH', '/');.

 define('HTTPS_COOKIE_PATH', '/');.

 define('DIR_WS_HTTP_CATALOG', '/catalog/');.

 define('DIR_WS_HTTPS_CATALOG', '/catalog/');.

Thanks so much..

Joseph..

Comments (58)

Hmm... I need to find out myself. I don't know what is the right answer to your question. I'll do some research and get back to you if I discover an useful answer. You should email the people at iPage as they probably could assist you..

Comment #1

Ok, I found a bug that was causing it and have fixed it...

Comment #2

And I am sure you are going to share your fix ? .

Regards.

The_Bear..

Comment #3

I was getting sleepy when I wrote that..

What I finally discovered after searching everywhere for an answer was that the two cookies "communicate" via a cache file. While modding osC to fit into the rest of my iPage site I neglected to change to cache file path. That fixed the problem..

MS1 worked differently for me (only one cookie from https domain) which is why I thought it was strange to see two cookies. It seems MS2 uses two cookies and cache to solve the shared SSL problem..

Joseph..

Comment #4

Hi j007w, I realise this is an old post, but I'll give it a bash anyway..

I'm having a problem when I set force cookie use to true..

Whenever a customer has something in their cart and clicks on checkout, everything in the cart disappears. As far as I can gather, it is because I use a shared SSL and there are two cookies generated; one on http, and one on https, the http cookie holding the cart info..

Your comment about MS2 using cache to communicate between the two cookies sounds like it could solve my problem, how do I go about checking/fixing it?.

Thanks.

James...

Comment #5

This is something that I got fixed when I added session_force_cooke to MS1. I have just installed MS2..

The problem is that, with force cookies on, when I login I get transferred to the secured page, My account, showing my old cart items. But when I go to any unsecured pages I'm no longer logged in. Going back to secured page I'm logged in already..

I see there're two cookies stored: each from http and https domains. So there are two cookie sessions at the same time but they don't "talk" to one another..

Should there be 2 cookies? MS2 is fixed for shared SSL which is what I'm using. Please help!.

My "configure.php".

Define('HTTP_SERVER', 'http://www.domain.net'); // eg, http://localhost - should not be empty for productive servers.

 define('HTTPS_SERVER', 'https://secure.domain.com/~user'); // eg, https://localhost - should not be empty for productive servers.

 define('ENABLE_SSL', true); // secure webserver for checkout procedure?.

 define('HTTP_COOKIE_DOMAIN', '.domain.net');.

 define('HTTPS_COOKIE_DOMAIN', 'secure.domain.com');.

 define('HTTP_COOKIE_PATH', '/');.

 define('HTTPS_COOKIE_PATH', '/');.

 define('DIR_WS_HTTP_CATALOG', '/catalog/');.

 define('DIR_WS_HTTPS_CATALOG', '/catalog/');.

Thanks so much..

Joseph..

Comment #6

Hi,.

Does anyone know how to fix this? My iPage site was already live and now it's broke not letting customers make purchase..

Thanks so much..

Joseph..

Comment #7


This question was taken from a support group/message board and re-posted here so others can learn from it.